Was ist passiert?

Meine Virtualisierungslösung in der DMZ läuft aktuell ohne Anschluss an eine Windows Active Directory Domäne. Somit werden meine virtualisierten DMZ-Server je in einer Arbeitsgruppe  betrieben. Das macht den globalen Betrieb natürlich nicht einfacher! Die Härtungsmaßnahmen sind soweit durchgeführt und darunter fallen natürlich auch regelmäßige Kennwortänderungen der lokalen Benutzerkonten.

Gestern war es wieder soweit, und ich änderte die Kennwörter der Benutzerkonten je VM in der DMZ. Anschließend habe ich in der Veeam Backup & Replication Installation die entsprechenden „Credentials“ mit dem neuen Kennwort hinterlegt. Heute morgen dann die Erkenntnis, dass der Backup-Job fehlgeschlagen ist!

Problem

So ist es mir heute passiert, dass ein Backup-Job in meiner Veeam Backup & Replication Installation immer mit einem Fehler abgebrochen ist:

Unable to allocate processing resources. 
Error: Unable to find Hyper-V hosts where VM 'xxx' is registered

Lösung

Die Lösung ist so banal wie einfach…

Es reicht aus, entweder den Veeam Server komplett neu zu starten oder eher die elegante Lösung, die Veeam Dienste entsprechend neu zu starten.

Hierzu nahm ich mir die PowerShell entsprechend zur Hilfe:

Get-Service | where {$_.Name -like "veeam*" -and $_.Status -eq "Running"} |` 
Restart-Service -WhatIf

(Achtung: entfernt zum Ausführen des Befehls zuvor noch am Ende den -WhatIf Parameter!)

Anschließend ist es wieder möglich, den fehlgeschlagenen Backup-Job erfolgreich durchlaufen zu lassen!

Background

In dem hier geschilderten Fall scheiterte der Verbindungsaufbau zum Backup-Dienst. Obwohl ich zuvor die hinterlegten „Credentials“ mittels der Veeam Konsole erfolgreich mit dem neuen Kennwort aktualisiert hatte! Somit reicht es nicht aus, nur die hinterlegten Credentials entsprechend zu aktualisieren!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Time limit is exhausted. Please reload CAPTCHA.